Windows 10

Antwort erstellen


Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern.

BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind ausgeschaltet

Die letzten Beiträge des Themas

Ich habe die Datenschutzerklärung gelesen und bin damit einverstanden.

   

Ansicht erweitern Die letzten Beiträge des Themas: Windows 10

Re: Windows 10

von Siggi » 22 Aug 2017, 18:02

Wenn die Themes so ein Ärger machen, sollten die evtl gesperrt oder an das Betriebssystem gekoppelt werden.

Heißt, Windows 10 geht halt nur das Windows theme. Oder eine Meldung, falls es doch verwendet wird.

Re: Windows 10

von ds10 » 21 Aug 2017, 14:26

Dafür hätte ich zwei einfache Lösungen, entweder du verwendest einfach das Windows-Thema anstatt das entsprechende Extended Windows oder du legst dir eine Verknüfpung für TV-Browser zum Starten an, die zusätzlich -Dos.version=6.2 enthält.

Re: Windows 10

von zebra2 » 21 Aug 2017, 11:45

Hier zwei Screenshots, die das Problem zeigen (die URL muss vorher natürlich noch korrigiert werden)

http://imgur.com/a/pejUj

http://imgur.com/a/qkYlM

[edit by uzi] links zwecks besserem handlings editiert + dummy beiträge gelöscht.

Re: Windows 10

von zebra2 » 21 Aug 2017, 11:42

Hi,

unter Windows 10 sieht die UI des TV Browser kaputt aus:
w10_2.PNG
(geht nicht)
w10_1.PNG
(geht nicht)

Das Problem ist die Windows-Versionserkennung von JGoodies:

Code: Alles auswählen

...
        IS_OS_WINDOWS_7 = startsWith(OS_NAME, "Windows") && startsWith(OS_VERSION, "6.1");
        IS_OS_WINDOWS_8 = startsWith(OS_NAME, "Windows") && startsWith(OS_VERSION, "6.2");
        IS_OS_WINDOWS_6_OR_LATER = startsWith(OS_NAME, "Windows") && startsWith(OS_VERSION, "6.");
...
Windows 10 hat als interne Versionsnummer 10.0 (siehe http__msdn.microsoft.com/de-de/library/windows/desktop/ms724832)

Eine einfache Lösung wäre, direkt bei Programmstart (vor jeglicher UI-Initialisierung) die System-Property "os.version" bei Windows 10 einfach auf 6.2 zu setzen.

PS: Der Trick einfach 5 Dummy-Beiträge zu schreiben, damit man Bilder und URLs posten kann hat leider nicht funktioniert :oops:

Nach oben